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Notes

The Ór program is regularly updated by its author, Martin Flynn of orienteering.ie. The information in 
this document is based on Ór version 4.3.x. If you are using a different version, the details of operation 
may differ slightly. The built-in Help in Ór can often answer your questions.

Change History

v.7.0: Revised section “Posting the Results”
v.8.0: Added note about Points Series
v.9.0: Some rewording; revised “Posting the Results”
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How to Run a NEOC E-Punch Meet (Club meet with “regular” courses)

The Big Picture

The main tasks involved when preparing for an E-punch meet are:
• Time-sync the controls, Start, Finish, etc. you will use, before they are set in the field (so that the

internal clock in each one is set identically). [approx. 30 mins.]
• Configure your courses on the club laptop, in the program Ór. [approx. 15 minutes]
• Charge the laptop and the thermal printer overnight (in case the generator fails).

For the Course-Setter

• Controls must have numeric codes to use the Ór meet software. 
• Things are easier for everyone if you do not re-number the e-controls. Talk to the Equipment 

Manager to find out what control numbers you'll get for your meet, and design your courses 
using those numbers.

• Get one or two extra controls, for backup in case a control fails.
• Sometime in the week before placing the e-controls in the field, time-sync to the SI-Master 

control the following:
• all the controls, including the Start and Finish controls
• the GeBe thermal printer's download box

See the document How to Sync E-Controls (available on neoc.org) for directions.

For the Meet Director

A day or two before the meet, you will need:

1. Club laptop with the download station (orange box with USB plug; this should be in the 
backpack with the laptop).

2. Club GeBE thermal printer with accessories; this should all be in one blue, plastic case.

Day of the meet, you will need:

1. Spare roll of thermal printer paper; this may be in the blue case with the printer, or in one of the 
loaner finger-stick cases.

2. Case(s) of loaner finger-sticks.
3. Clear, Check, Start, and Finish controls; and stands for the Start and Finish controls.
4. If venue does not have AC power: Club generator and fuel jug, club extension cord.
5. Club LCD display and its tripod (for live results).
6. Canopy/tarp(s) and rope to shelter the laptop and generator, if wet weather is expected.
7. A volunteer to enter runner info into Ór and manage downloads. At busy meets, you should have

two volunteers—one to check that Safety Cards are complete and legible (and to ensure Clear & 
Check), and one to enter info into Ór and manage downloads.

5/11/15 v.9.0 E-Meet Workflow 2



Tasks Before the Meet

Set up the event on the laptop

From the course setter, for each course that will be offered, get:
• the course name
• a list of control numbers, in order
• the course Length in kilometers (Purple Pen calculates this for you)
• the course Climb in meters (if available)

Then use the program Ór to set up all the courses for the event. Note that the built-in Help in Ór is very 
useful.

 1. Turn on the laptop, with the push-button on the right end of the screen hinge. [Password is the 
short name of your favorite O-club, lower-case.]

 2. Start the program Ór on the laptop.
 3. In Ór, click File > New Competition. The “Edit Competition” window will open.

 a) Enter “Competition Name” (e.g. “Prospect Hill - 14 November 2015”)
 b) Check that:

• “Type” is set to “Individual”
• “Time Format” is set to “mmm:ss”
•  “Calculated By” is set to “Course”

 c) Set “Zero Time” to a time before any runner could conceivably punch the first control. For 
our usual 10 AM starts, you could set this to “8:00:00”. The “Zero Time” is used for a runner 
who does not punch the Start control.

 d) Click “OK.”
 4. Define the courses:

In Ór, click Edit > Courses. The “Manage Courses” window will open. For each course to be 
offered, click “New”. The “Edit Course” window will open.
 a) Enter “Course Name” (e.g. “Orange”, “Sprint 1”, “Long”, “Toe-Stubber Night-O”)
 b) “Course Length” (in kilometers) and “Course Climb” (in meters) are optional, but 

appreciated. Don't enter units; just numbers.
 c) “Default Start Time” will be carried over from the Competition setting. (If this is a mass-start

course, enter an estimated start time and input the exact start time before the first finisher 
downloads.)

 d) Set “Course Type” to “Cross Country” for normal, punch-all-in-order events. For “Score” 
and “Scatter,” see Ór's Help.

 e) Click the “Variants” tab. Check that “Variant Type” is “Single.” In the “Controls” textbox, 
type the control numbers for this course, in order, with a semicolon after each one. Do not 
include Start and Finish in this list. (The list ends with a semicolon!)
This step is important – double-check this control list.

 f) Click “OK.”
 5. After all the courses are entered, click “Close” to exit the “Manage Courses” window.

Now you are ready to register runners. Remember that you can change any of the settings any time 
before the first runner starts, by using the Edit menu. This is handy if there is a last-minute control 
change.
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Prepare the laptop and thermal printer

The night before the meet:
1. Charge the laptop overnight, at least 10 hours to be safe. The power supply is in the backpack; it 

connects to the laptop at its right side.
2. Charge the thermal printer overnight. The power supply is in the printer's case. The charger 

connects to the front side of the printer.
3. [optional step] Boot up the laptop. Get connected to the Internet. 

For wireless connections:
• Press “Windows”-X (the key to the left of the spacebar with the Windows logo, together 

with X). The “Windows Mobility Center” will open. 
• Click “Turn wireless on”. When you are connected to the Internet, you will see 

“Connected” and green bars. 
• If you are having trouble connecting, press the F2 key to turn on/off the PC's antenna.

Start Ór.
• Click Internet > Get Archive... 

This will download NEOC's current database of finger-sticks.
• Quit Ór and Shut Down the laptop.
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Overview: The Day of the Meet

• Collect a Safety Card from each runner and verify that it is legible and complete.
• Instruct runner to Clear and Check, then direct them to Start.
• Use Ór on the laptop to record information from each Safety Card, and to download results from

each runner's finger-stick after finish.
• Use the thermal printer to give each runner a copy of his/her splits.
• Set Ór to display live results on the LCD monitor -or- copy runner's finish time to his/her Safety 

Card, then hang the card on the results string.
• Send final Results to Points Series person.
• Compose a Results page for the website (or e-mail the results files to the Results Coordinator).

Before the first start - Set up the gear

1. Set up the laptop where it will be safe from rain, and near the Start and Finish (if possible).
2. There is a power-strip in the backpack. If you don't have access to a power outlet, set the 

generator in a clear, level place away from people. Start the generator and run the extension cord 
to the laptop table.

3. Plug in the laptop and the LCD monitor. Connect the monitor's data cable to the port on the left 
side of the laptop.

4. Turn on the laptop and start Ór. 
5. Plug the orange download box (stored in the backpack) into one of the USB ports on the laptop. 

Near the top of the Ór window, set “Com Port” to “COMx” (COM3, COM6, ...). The text next to
“Com Port” will change from red “Connecting” to green “Open” (after about 10 seconds). 
(Never unplug the download station while Ór is running!)

6. Look at the title bar of Ór. If your event is not displayed there, click File > Open Competition 
and select your event.

7. In Ór, click Tools > Result Screen. Drag the “Live Results” window to the right until it is visible 
on the LCD, then maximize it to use the entire LCD display.

8. In the blue printer case, find the thermal printer, paper tape, and download box velcro-ed to the 
orange board. Place the orange board near the laptop. Check that the download box is plugged 
into the printer. Connect the power supply and plug it in.

9. Take a roll of printer paper. “Thread” it under the hinge edge of the printer's paper hatch and out 
the opposite side of the hatch. The paper should curl up as it exits the printer.

10. Find the purple “Clear Backup” stick, tethered by a string to the printer rig. Dip it into the 
printer's download box to erase any old downloads. (DO NOT do this during your event!)

11. Verify that the printer is connected properly. Dip any finger-stick into the printer's download box.
Even if the stick has been cleared, it should print a few lines. 

12. Clip a Clear and Check control onto the orange board for this purpose (in the “Start box”), and 
set it out in front of the laptop.

13. Before the first starter, use a purple “Clear Backup” key (in the blue box with the SI-Master) to 
clear the Start control(s) you'll be using. (This will enable Ór to read the “started” runners later 
in the meet, and give you a list of who is still out.)
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During the Meet

Collect a Safety Card from each runner

• Collect the runner's Safety Card. Verify that the Safety Card is legible and complete.
For groups, note the number of people; e.g. “Team Greyhound (4)” or “Joe Needle +2”. 

• Instruct the runner to Clear and Check his/her stick, then direct the runner to the Start. 
• E-punch runners can usually self-start. Request runners on the same course to wait a couple of 

minutes, then self-start.
• Remind newbies to punch Start before running off, and to return for download when done (even 

if abandoning the event!). All runners must download so we know they're out of the woods.

When you have a break in activity, enter info from Safety Cards into Ór

Find the “Add New Competitor” section in the upper-left part of the Ór window.
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 1. Enter the runner's finger-stick number (“SI Number”). Beware of transposing digits.
 2. Press “Tab” to advance the cursor to the next input field.

• If the stick is a NEOC loaner stick, the “Rented” checkbox will be checked, and the 
cursor will land in the “Name” field. Enter the runner's first and last names. For groups, 
enter at least one name and a count of others in the group (e.g., “Sue Loadstone +3”). 
Please check that your spelling is correct – this information will live on the website for 
years to come.

• If the stick belongs to a runner who has registered it with NEOC, his/her name and club 
will fill-in automatically, and the cursor will land on the “Course” drop-down.

 3. Select the runner's Course.
 4. Optional: Select the runner's Club. If the club isn't in the pull-down list, click the “+” button to 

add it to the list, then select it from the list.
 5. Very optional: Select the runner's Class.
 6. Click “OK.” 

You may get a warning that the finger-stick has already been used by another runner. (This often 
happens with loaner sticks late in a meet.) Verify that the stick number is correct, and click “Yes”
to re-use the stick.

 7. File the Safety Card by course in the start-card box.

Tips:
• “Alt-e” moves the cursor to the “SI Number” field, ready to Enter a new runner.
• Use “Tab” to move to the next field; Shift-Tab to move to the previous field. The active field 

will have a (slightly) bold label.
• When the “Rented” checkbox is active, “Space” will toggle it checked/unchecked.
• When a pull-down is active, hit the first letter of your choice to select it. For example, when 

“Course” is active, hit “O” to select “Orange.” Multiple hits will cycle through options 
having the same first letter. For example, when “Club” is active, hit “E” to step through 
EMPO, EOC, EOOC.

When a runner finishes, capture his/her finger-stick data

Every runner must download after leaving the course. (For safety, and other reasons.)
1. Dip the finger-stick into the download box of the thermal printer. The printed splits are for the 

runner's information.
2. Dip the finger-stick in the orange download station until it beeps. The download will be reported 

at the top of the right-side window. 
Look at this information before the runner walks away!!!

3. Verify that the runner's name and time appear at the top of the right-side window (it could take a 
few seconds). If not, download again.

4. Repeat the displayed name to the runner. 
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If the name is wrong, then the previous user of that stick did not download: 
• find the previous user of that stick in the list at left (sort the list by “SI Num”); 

previous user will have the same stick number and a Yellow or Red status. 
• double-click the previous user's name in the list
• click the “Extras” tab
• set “Status” to DNF
• click “OK” to close the runner details
• ask the current runner to download again (repeat from step 1.)

If the name is “Unknown,” then the runner's stick number was entered incorrectly or the runner's 
info was not entered at all. The download will appear in the lower-right pane on the tab “Extra 
Downloads.” Once Ór sees the name/course info for that stick number, its entry will disappear 
from “Extra Downloads.”: 

• if you find the runner's name in list of runners, double-click the name and correct the 
stick number.

• otherwise, find the runner's Safety Card in the to-be-entered pile, and enter his/her 
information.

5. A list of control numbers may appear after the name: punched controls (in green), “extra 
controls” (in yellow), and missed controls (in red). “DNF” will appear in red if controls were 
missed.

Note: If a DNF runner convinces you that a missing control was actually punched (the printed 
splits may substantiate this claim), edit the downloaded data:

• double-click the runner name in the list at the left
• click the “Extras” tab
• click “Edit Punches”
• click the “Add xxx” button to add the missed control
• click “OK” to close the list of controls
• click “OK” to close the runner details

Note: If it looks like the runner missed a LOT of controls (red #s) or has a lot of “extra” controls 
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(yellow #s), check that he/she was input as running the correct course. If the course is wrong:
• double-click the runner name in the list at the left
• change the Course drop-down to the correct course

Note: If the runner has an unusually long Time result, find the runner's entry in the list at left; 
check the time in the Start column. If the Start time is 8:00:00 (or whatever you set for “Zero 
Time” in Ór), the runner did not punch the Start control. Look at the splits printout for the time 
at the first control, and estimate the Start time. Double-click the runner name to open the Details 
window, and input Start Time on the “Extras” tab.

 5. *** RENTED *** will appear if the runner is using a loaner stick. Remind him/her to return it.
 6. If you're hanging results on the string, record the finish time on the runner's Safety Card and 

hang by course.

While the meet is in progress

• optional: Whenever you have a lull in the action, make a safety backup of Ór's data.
Click File > Export > Competition... to save the event data. Save it with a name and location 
you'll remember.

• Keep an eye on the battery level of the laptop (right end of the taskbar). If it gets too low, plug it 
in using a local outlet, the club generator, or a car's “accessory” cigarette-lighter. There is a 
power adapter in the backpack that will let you plug the computer's power cord into a car. If the 
car has a second, “accessory” lighter, it's usually better to use that one.

After “Starts” closes

• You can keep track of who is still on the course by downloading the Start control(s) into Ór. 
(This will not identify a runner who punched Start, but left without downloading, or a runner 
who did not punch Start.) 
Note: This will only work if the Start control(s) was cleared before the first runner. See “Before 
the First Start” above.

1. Use the gray coupling rod to connect the Start box to the download box.
2. In Ór, click Tools > Read Start Unit (Repeat from step 1 if there are multiple Start 

boxes.)
3. After the Start box is read, the status indicators (colored dots in left column of runners 

list) will be updated. 
Yellow = registered in Ór, but did not punch Start
Red = started, but did not yet download (still on course or went home)
Green = finished
Purple = finished, but DNF

At the end of the meet

• Ideally, all of the colored dots in the left column of entrants should be either green (downloaded 
OK) or purple (downloaded DNF). 

• Yellow and Red dots show runners who have not downloaded – they may still be in the woods, 
or they went home without downloading, or they downloaded but Ór could not match the 
download's stick number with any stick number in the runners list. 

• Check the “Extra Downloads” tab in the lower-right pane. These are downloads that Ór could 
not match with any stick number in the runners list. The runner's stick number may have been 
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entered incorrectly, or the runner was not entered at all. Look for Safety Card(s) with that stick 
number. If the stick number is wrong in the runners list, correct it there.

• Check the “Extra Starts” tab in the lower-right pane. These are finger-sticks that punched Start, 
but have not yet downloaded. Either the runner is in the woods, or he/she went home without 
downloading. If the stick number is for a loaner stick, see if that stick has been returned (an 
indication that the runner went home).

• If you are certain that an entry does not belong in Ór's list (e.g. a runner was entered twice), 
delete the extraneous entry: click the entry to select it, right-click the entry, click “Delete” in the 
pop-up menu.

• When all runners are accounted for, make a final backup of the Ór data (File > Export > 
Competition...), and shut down the laptop.

• Check that all finger-sticks have been returned.

General Notes

• The clock on the laptop is set to “military time.” Do not change that setting.
• The laptop is set to a power-saver mode so the battery will last about 6 hours on a full charge.

Please do not change that setting.
• After a long period of inactivity, the laptop will go to Sleep. Press the power button to log 

back in.
• Never unplug the orange download station from the laptop while Ór is running! If you 

MUST unplug the download station, quit Ór first. After re-connecting the station, don't 
forget to set Ór's Com Port back to COMx.

• The Windows application “SPORTident.ConfigPlus” can be used to program controls. This is
not recommended, and should not be necessary.
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Posting the Results

You can either compose the Results page yourself (much appreciated), or e-mail the results file and 
splits file to the results coordinator. 

Export the results and splits

 1. On the laptop, start Ór. 
 2. Verify that your event is loaded in Ór by looking for the event name in the titlebar of Ór's 

window. If your event is not loaded, click File > Open Competition. Select your event from the 
list and click “OK.”

 3. Export the splits (to be used later)
 a. Click File > Export > Splits in CSV...
 b. Name the file something like “prospectHill_04Nov11.csv.” Remember the name and location

of the .csv file you are exporting. Click the Save button.
 4. Export the results

 a. Click File > Save > Save Results...
 b. Name the file something like “prospectHill_04Nov11” (the “.html” extension will be added 

automatically). Remember the name and location of this file. Click the Save button.
 5. Quit Ór.

Send a copy of the results html file to pointscompetition@newenglandorienteering.org so your event is 
included in the Points Series.

To get the results posted, you can e-mail the two files (results and splits) with a note, to 
resultscoordinator  @newenglandorienteering.org, and wait for him/her to post the results.

Alternatively, you can compose the Results page yourself. The process is very similar to composing an
e-mail message on Gmail or Yahoo. Note that each make of browser behaves slightly differently; be 
flexible as you follow these steps. You need to have Author (or higher) privileges on the NEOC website 
to perform this task (send request to webmaster@newenglandorienteering.org). 

First you will post the splits on WinSplits, then post the results (with a link to the splits) on NEOC.org.

Post the Splits on WinSplits

WinSplits is a site that lets anyone in the world post splits for their O-events. Post the splits from your 
event first, then you can put a link to those splits in with the event results on the NEOC site.

1. Connect the laptop to the Internet (or transfer the splits and results files to a computer with 
Internet access.)

2. In your browser, load the WinSplits homepage: http://www.obasen.nu/winsplits/online/en
3. Click the link below the header: “Upload split times”
4. Set the “file format” to “Sport Software CSV” and click the “Next >>” button.
5. In the “zero time” field, enter the “Zero Time” that was set for your event in Ór. You can find 

this by opening the event in Ór, and clicking the menu Edit > Competition. Enter the time as 
hh.mm.

6. Enter your e-mail address. WinSplits will send you logon info for your splits, in case you want to
go back and change anything.

7. Next to “split time file,” click the button to navigate to the .csv file you output from Ór.
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8. Click the “Next >>” button. Wait while WinSplits uploads your .csv file.
9. If WinSplits finds your information and splits file to be complete and valid, it will prompt you to 

input:
a. “event name” - enter something like “Mt. Tom Reservation”
b. “organizer” - enter “New England Orienteering Club” (please spell it out)
c. “country” - set to “USA”
d. “date” - enter the date of the meet as dd/mm/yyyy
e. “classification” - set to “local event” (for A-meets, use “national event”)

10. Click the “Next >>” button.
11. WinSplits will display a summary of your event. Check that your e-mail address is correct, and 

that all your courses are represented. To make corrections, click the “<< Previous” button. If all 
is OK, click the “Next >>” button.

12. WinSplits will display a final screen. Leave this window open – it contains three pieces of 
information:
a. The URL of your event splits page.
b. An Event number and Password for your event. (You should also receive this info via e-

mail.) Make a note of these – you'll need them if you have to update the splits or edit other 
info.

c. Click the URL of your event splits. WinSplits will open in another browser window/tab. 
Click each course and check that there is a column for each control. If there is a problem, 
the .csv file needs to be edited by hand. Forward the email you received from WinSplits, with
the splits .csv file attached, to resultscoordinator@newenglandorienteering.org.

Post the Results on NEOC.org

 1. Format the results for the NEOC website:
 a. Right-click on the results file you exported in step 4 of “Post the finish times...” above 

(yourMeet.html), and select “Open with” > “OpenOffice.org Calc.”
Note: OpenOffice is installed on the NEOC laptop. Microsoft Excel will work as well.

 b. The OpenOffice “Import Options” window will appear. Click “OK” to proceed. The results 
will appear in a spreadsheet.

 c. Delete the first few rows above the heading for your first course.
 d. Drag the borders of column headers to get a layout that will look nice as a Web page. Narrow

column A, widen column B so that the runners' names don't wrap, narrow the columns of 
club names and finish times, etc.

 e. If Class is unused, delete its column (usually C) – right-click on the column header and select
“Delete Selected Columns” from the pop-up menu.

 f. Delete any blank rows below each course heading.
 g. For each course heading, click-drag across the 4 or 5 cells in the heading row to select them, 

right-click, and select “Merge Cells” from the pop-up menu. Click “Yes” in the pop-up that 
follows.

 h. For each course, set the background color of the course name:
• Click the cell containing the course name.
• In the toolbar at top, click the “tipping paint-bucket” icon, and select a background color 

to match the course. (Set Sprints to purple.)
• Press Ctrl-B to bold the course name.

 i. Keep this spreadsheet open.
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 2. Create a new website article of event results:
 a. Open a new browser window (keep the WinSplits info window open). Load: 

http://www.newenglandorienteering.org/
 b. Scroll to the bottom of the page, and click the small O-control flag in the right corner. The 

login page will load.
 c. Log in using the username and password provided by the Webmaster.
 d. If your login is successful, you will see a page with a block of “Account Options” at the top 

of the left-hand column. Click “Submit an Article.” You will see a form for your new article.
 e. In the Title field, enter the location and date of the event (e.g. “Prospect Hill – October 18, 

2015”).
 f. In the composition window (below the edit icons), enter a heading for the meet. These are 

usually like:
                      Mt. Tom Reservation, Holyoke, MA
                                        June 11, 2015
                             Meet Director: Ian Smith

 g. Notes:
• To make a simple new-line (tighter line spacing as in the 3-line header above), press 

Shift-Enter; to make a new paragraph, press Enter.
• To bold the first line, select the text and click the “B” button in the edit icons.
• To center a paragraph, set your cursor anywhere in a line and click the “Align center” 

icon.
• If after repeated editing your page “just won't format correctly,” click Cancel (top-right) 

and start over.
 h. After the 3-line header, press Enter at least once, and type something like:

 Split times are here (courtesy of WinSplits).
 i. Select the word “here” in that line, then click the “chain” icon in the top row of edit icons. (If

you hover over it, “Insert/Edit link” will pop up.)
 j. The “Link” window will open. Copy the URL of your splits from the WinSplits page (it will 

be something like: http://www.obasen.nu/winsplits/online/en/show_event.asp?id=22578). 
Paste it into the URL field of the Link window.

 k. Near the bottom of the Link window, set “Target” to “Open in new window”.
 l. Click the “Insert” button to close the Link window.
 m. In the open spreadsheet of results, select the cells that you want on the website. That is, click 

the title cell of the first course, then hold the Shift key down and click the finish time of the 
last finisher of the last course.

 n. Press Ctrl-C to copy the results.
 o. In the Web browser, click after your splits link, and press Enter at least once. Press Ctrl-V to 

paste the table of results. Look over your page and make any edits.
 p. Click the “Publishing” tab near the top of the page. Set  “Category” to “2015 Event Results” 

(select the current year).
 q. Leave the other settings unchanged.
 r. Scroll to the top of the webpage, and click “Save.”
 s. Click the “Logout” button at the top of the left column.
 t. Your article is now submitted to the website. Depending on your account privileges, it may 

need to be reviewed before it appears online.
Thank you for your submission!
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 u. Exit OpenOffice, and Discard your changes to the spreadsheet.
 v. Keep the .csv file and .html file for future reference. (On the Desktop of the laptop is a folder

“Posted_Events.” Open this folder, and in it create a folder for your event. Store the .csv 
and .html files there.)

<TBD – how to post an event in RouteGadget>
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